# Openbsd-as-a-Desktop-OS # Upgrade OpenBSD ## Patch Base System ```bash syspatch ``` ## Upgrade system ```bash sysupgrade ``` ## Upgrade Packages ```bash pkg_add -u ``` # Package Management ## Search for a package ```bash pkg_info -Q ``` ## Get Info about package ```bash pkg_info ``` ## install package ```bash pkg_add ``` # System Enhancement If you have an SSD you can edit ```/etc/fstab``` and add attribute ```softdep``` # Download and Configure Ports tree ```bash ftp https://cdn.openbsd.org/pub/OpenBSD/$(uname -r)/{ports.tar.gz,SHA256.sig} signify -Cp /etc/signify/openbsd-$(uname -r | cut -c 1,3)-base.pub -x SHA256.sig ports.tar.gz tar xzvf /tmp/ports.tar.gz -C /usr ```